Every CVE Search/ Get API key

CVE-2011-1092

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to...

7.5 HighPublic exploitFix available

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop_read function.

Exploit likelihood

17.9%Up 5.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop_read function.

Record
CVE-2011-1092
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop_read function.

Record
CVE-2011-1092
Updated
2026-11-02
EUVDEUVD-2011-1106 No score

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop_read function.

Record
EUVD-2011-1106
Updated
2026-11-03
GitHub AdvisoriesGHSA-2gm5-2gjp-759h No score

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to...

Integer overflow in ext/shmop/shmop.c in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (crash) and possibly read sensitive memory via a large third argument to the shmop_read function.

Record
GHSA-2gm5-2gjp-759h
Updated
2026-11-02
OSVopenSUSE-SU-2024:10290-1 No score

apache2-mod_php7-7.0.14-1.4 on GA media

These are all security issues fixed in the apache2-mod_php7-7.0.14-1.4 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10290-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10344-1 No score

apache2-mod_php5-5.6.28-1.1 on GA media

These are all security issues fixed in the apache2-mod_php5-5.6.28-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10344-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11169-1 No score

php8-8.0.11-1.1 on GA media

These are all security issues fixed in the php8-8.0.11-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11169-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
php5
Debian:6.0
before 5.3.3-7+squeeze8, plus listed versions
5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze25.3.3-7+squeeze35.3.3-7+squeeze55.3.3-7+squeeze65.3.3-7+squeeze7
5.3.3-7+squeeze8
php7
openSUSE:Tumbleweed
before 7.0.14-1.4
7.0.14-1.4
php5
openSUSE:Tumbleweed
before 5.6.28-1.1
5.6.28-1.1
php8
openSUSE:Tumbleweed
before 8.0.11-1.1
8.0.11-1.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBPHP 5.3.6 - 'shmop_read()' Integer Overflow Denial of Service2011-03-12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1092 is a high vulnerability (CVSS 7.5) in Php, published March 15, 2011. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 17.9%, the 97th percentile. Fixed in php5 5.3.3-7+squeeze8.

References

Show 129 moreShow less
MoveEnter Open