Every CVE Search/ Get API key

CVE-2011-1156

feedparser denial of service vulnerability

5.0 MediumFix available

CVE-2011-1156 is a medium vulnerability (CVSS 5.0) in Mark Pilgrim Feedparser, published April 11, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.26%, the 88th percentile. Fixed in feedparser 5.0.1.

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Exploit likelihood

3.26%Up 1.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
CVE-2011-1156
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
CVE-2011-1156
Updated
2026-11-02
EUVDEUVD-2011-0014 No score

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
EUVD-2011-0014
Updated
2026-11-03
GitHub AdvisoriesGHSA-6h52-4vmh-8x4f 8.7

feedparser denial of service vulnerability

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
GHSA-6h52-4vmh-8x4f
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-6h52-4vmh-8x4f 8.7

feedparser denial of service vulnerability

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
GHSA-6h52-4vmh-8x4f
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-20
Updated
2026-11-02
OSV No score

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
CVE-2011-1156
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1156 No score

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
DEBIAN-CVE-2011-1156
Updated
2026-11-02
OSVPYSEC-2011-19 No score

feedparser.py in Universal Feed Parser (aka feedparser or python-feedparser) before 5.0.1 allows remote attackers to cause a denial of service (application crash) via a malformed DOCTYPE declaration.

Record
PYSEC-2011-19
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
feedparser
PyPI
4.1 up to 5.0.1
5.0.1
feedparser
Debian:12
before 5.0.1-1
5.0.1-1
feedparser
Debian:13
before 5.0.1-1
5.0.1-1
feedparser
Debian:14
before 5.0.1-1
5.0.1-1
feedparser
PyPI
4.1 up to 5.0.1, plus listed versions
5.0
5.0.1
feedparser
PyPI
before 5.0.1, plus listed versions
4.15.0
5.0.1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 11 moreShow less
MoveEnter Open