CVE-2011-1464
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration...
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration option has a large value, might allow context-dependent attackers to cause a denial of service (application crash) via a small numerical value in the argument.
Exploit likelihood
What each source reports
NVD Score used
4.3
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration option has a large value, might allow context-dependent attackers to cause a denial of service (application crash) via a small numerical value in the argument.
- Record
CVE-2011-1464- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration option has a large value, might allow context-dependent attackers to cause a denial of service (application crash) via a small numerical value in the argument.
- Record
CVE-2011-1464- Updated
- 2026-11-02
EUVDEUVD-2011-1469 No score
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration option has a large value, might allow context-dependent attackers to cause a denial of service (application crash) via a small numerical value in the argument.
- Record
EUVD-2011-1469- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3ghw-r8fh-hc2p No score
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration...
Buffer overflow in the strval function in PHP before 5.3.6, when the precision configuration option has a large value, might allow context-dependent attackers to cause a denial of service (application crash) via a small numerical value in the argument.
- Record
GHSA-3ghw-r8fh-hc2p- Weakness
- CWE-119
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php5Debian:6.0 |
before 5.3.3-7+squeeze8, plus listed versions 5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze25.3.3-7+squeeze35.3.3-7+squeeze55.3.3-7+squeeze65.3.3-7+squeeze7 |
5.3.3-7+squeeze8 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1464 is a medium vulnerability (CVSS 4.3) in Php, published March 20, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.80%, the 86th percentile. Fixed in php5 5.3.3-7+squeeze8.