CVE-2011-1470
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of...
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.
Exploit likelihood
What each source reports
NVD Score used
4.3
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.
- Record
CVE-2011-1470- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.
- Record
CVE-2011-1470- Updated
- 2026-11-02
EUVDEUVD-2011-1475 No score
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.
- Record
EUVD-2011-1475- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-38v8-mx2q-3jp7 No score
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of...
The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.
- Record
GHSA-38v8-mx2q-3jp7- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php5Debian:6.0 |
before 5.3.3-7+squeeze8, plus listed versions 5.3.3-75.3.3-7+squeeze15.3.3-7+squeeze25.3.3-7+squeeze35.3.3-7+squeeze55.3.3-7+squeeze65.3.3-7+squeeze7 |
5.3.3-7+squeeze8 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | PHP 5.3.x 'Zip' Extension - 'stream_get_contents()' Denial of Service | 2011-03-10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1470 is a medium vulnerability (CVSS 4.3) in Php, published March 20, 2011. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 9.52%, the 95th percentile. Fixed in php5 5.3.3-7+squeeze8.