CVE-2011-1497
Cross site scripting in actionpack Rubygem
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
- Record
CVE-2011-1497- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
- Record
CVE-2011-1497- Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-1807 No score
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
- Record
EUVD-2022-1807- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q58j-fmvf-9rq6
6.1
Cross site scripting in actionpack Rubygem
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
- Record
GHSA-q58j-fmvf-9rq6- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-q58j-fmvf-9rq6
6.1
Cross site scripting in actionpack Rubygem
A cross-site scripting vulnerability flaw was found in the auto_link function in Rails before version 3.0.6.
- Record
GHSA-q58j-fmvf-9rq6- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
actionpackRubyGems |
3.0.0.rc up to 3.0.6 | 3.0.6 |
actionpackRubyGems |
3.0.0.rc up to 3.0.6, plus listed versions 3.0.03.0.0.rc23.0.13.0.23.0.3 Show 6 moreShow less3.0.43.0.4.rc13.0.53.0.5.rc13.0.6.rc13.0.6.rc2 |
3.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1497 is a medium vulnerability (CVSS 6.1) in Rails, published October 19, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.29%, the 70th percentile. Fixed in actionpack 3.0.6.
References
openwall.com/lists/oss-security/2011/04/06/13
github.com/rails/rails/blob/38df020c95beca7e12f0188cb7e18f3c37789e20/actionpack/CHANGELOG
nvd.nist.gov/vuln/detail/CVE-2011-1497
github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2011-1497.yml
github.com/rails/rails/commit/61ee3449674c591747db95f9b3472c5c3bd9e84d
github.com/rails/rails/commit/ab764ecbfea31a3b14323283287e2fc80955ace6
github.com/advisories/GHSA-q58j-fmvf-9rq6
github.com/rails/rails