Every CVE Search/ Get API key

CVE-2011-1522

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform:...

7.5 HighFix available

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Exploit likelihood

2.02%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
CVE-2011-1522
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
CVE-2011-1522
Updated
2026-11-02
EUVDEUVD-2011-1523 No score

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
EUVD-2011-1523
Updated
2026-11-03
GitHub AdvisoriesGHSA-h7q6-v9rj-35qf No score

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform:...

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
GHSA-h7q6-v9rj-35qf
Weakness
CWE-89
Updated
2026-11-02
OSV No score

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
CVE-2011-1522
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1522 No score

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Record
DEBIAN-CVE-2011-1522
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
doctrine
Debian:12
before 1.2.4-1
1.2.4-1
doctrine
Debian:13
before 1.2.4-1
1.2.4-1
doctrine
Debian:14
before 1.2.4-1
1.2.4-1
doctrine
Debian:6.0
before 1.2.2-2+squeeze1, plus listed versions
1.2.2-2
1.2.2-2+squeeze1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1522 is a high vulnerability (CVSS 7.5) in Doctrine-project Doctrine, published April 20, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.02%, the 81st percentile. Fixed in doctrine 1.2.4-1.

References

Show 4 moreShow less
MoveEnter Open