CVE-2011-1587
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or...
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
CVE-2011-1587- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
CVE-2011-1587- Updated
- 2026-11-02
EUVDEUVD-2011-1587 No score
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
EUVD-2011-1587- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-28vc-7qpm-6gqr No score
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or...
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
GHSA-28vc-7qpm-6gqr- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
CVE-2011-1587- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-1587 No score
Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.
- Record
DEBIAN-CVE-2011-1587- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mediawikiDebian:12 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:13 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:14 |
before 1:1.15.5-5 | 1:1.15.5-5 |
mediawikiDebian:6.0 From an advisory covering 6 CVEs |
before 1:1.15.5-2squeeze2, plus listed versions 1:1.15.5-21:1.15.5-2squeeze1 |
1:1.15.5-2squeeze2 |
mediawikiDebian:5.0 From an advisory covering 6 CVEs |
before 1:1.12.0-2lenny9, plus listed versions 1:1.12.0-2lenny21:1.12.0-2lenny31:1.12.0-2lenny3~bpo40+11:1.12.0-2lenny41:1.12.0-2lenny51:1.12.0-2lenny61:1.12.0-2lenny71:1.12.0-2lenny8 |
1:1.12.0-2lenny9 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-1587 is a medium vulnerability (CVSS 4.3) in Mediawiki, published April 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.71%, the 77th percentile. Fixed in mediawiki 1:1.15.5-5.
References
openwall.com/lists/oss-security/2011/04/18/5
debian.org/security/2011/dsa-2366
bugzilla.redhat.com/show_bug.cgi?id=696360
lists.wikimedia.org/pipermail/mediawiki-announce/2011-April/000097.html
nvd.nist.gov/vuln/detail/CVE-2011-1587
github.com/advisories/GHSA-28vc-7qpm-6gqr
security-tracker.debian.org/tracker/CVE-2011-1587