Every CVE Search/ Get API key

CVE-2011-1755

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows...

7.5 HighFix available

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

3.66%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-1755
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-776
Updated
2026-11-02
CVE List No score

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-1755
Updated
2026-11-02
EUVDEUVD-2011-1754 No score

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
EUVD-2011-1754
Updated
2026-11-03
GitHub AdvisoriesGHSA-rpcf-xw9j-7c7j 7.5

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows...

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
GHSA-rpcf-xw9j-7c7j
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-776
Updated
2026-11-02
OSV 7.5

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
CVE-2011-1755
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1755 7.5

jabberd2 before 2.2.14 does not properly detect recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted XML document containing a large number of nested entity references, a similar issue to CVE-2003-1564.

Record
DEBIAN-CVE-2011-1755
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jabberd2
Debian:12
before 2.2.8-2.1
2.2.8-2.1
jabberd2
Debian:13
before 2.2.8-2.1
2.2.8-2.1
jabberd2
Debian:14
before 2.2.8-2.1
2.2.8-2.1
jabberd
Red Hat:network_proxy:5.4::el5
before 0:2.2.8-12.el5sat
0:2.2.8-12.el5sat
jabberd-debuginfo
Red Hat:network_proxy:5.4::el5
before 0:2.2.8-12.el5sat
0:2.2.8-12.el5sat
jabberd
Red Hat:network_satellite:5.4::el5
before 0:2.2.8-12.el5sat
0:2.2.8-12.el5sat
jabberd-debuginfo
Red Hat:network_satellite:5.4::el5
before 0:2.2.8-12.el5sat
0:2.2.8-12.el5sat

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1755 is a high vulnerability (CVSS 7.5) in Jabberd2, published June 21, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.66%, the 89th percentile. Fixed in jabberd2 2.2.8-2.1.

References

Show 21 moreShow less
MoveEnter Open