Every CVE Search/ Get API key

CVE-2011-1778

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service ...

6.8 MediumFix available

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Exploit likelihood

4.20%Down 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
CVE-2011-1778
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
CVE-2011-1778
Updated
2026-11-02
EUVDEUVD-2011-1776 No score

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
EUVD-2011-1776
Updated
2026-11-03
GitHub AdvisoriesGHSA-j8fm-g3qm-7gm3 No score

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service ...

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
GHSA-j8fm-g3qm-7gm3
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
CVE-2011-1778
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1778 No score

Buffer overflow in libarchive through 2.8.5 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted TAR archive.

Record
DEBIAN-CVE-2011-1778
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libarchive
Debian:12
before 2.8.5-5
2.8.5-5
libarchive
Debian:13
before 2.8.5-5
2.8.5-5
libarchive
Debian:14
before 2.8.5-5
2.8.5-5
libarchive
Debian:6.0
From an advisory covering 2 CVEs
before 2.8.4-1+squeeze1, plus listed versions
2.8.4-1
2.8.4-1+squeeze1
libarchive
Red Hat:enterprise_linux:6::server
From an advisory covering 2 CVEs
before 0:2.8.3-3.el6_1
0:2.8.3-3.el6_1
libarchive-debuginfo
Red Hat:enterprise_linux:6::server
From an advisory covering 2 CVEs
before 0:2.8.3-3.el6_1
0:2.8.3-3.el6_1
libarchive-devel
Red Hat:enterprise_linux:6::server
From an advisory covering 2 CVEs
before 0:2.8.3-3.el6_1
0:2.8.3-3.el6_1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1778 is a medium vulnerability (CVSS 6.8) in Freebsd Libarchive, published February 20, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.20%, the 91st percentile. Fixed in libarchive 2.8.5-5.

References

Show 12 moreShow less
MoveEnter Open