Every CVE Search/ Get API key

CVE-2011-1782

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro ...

7.5 HighFix available

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Exploit likelihood

3.43%Down 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
CVE-2011-1782
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
CVE-2011-1782
Updated
2026-11-02
EUVDEUVD-2011-1780 No score

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
EUVD-2011-1780
Updated
2026-11-03
GitHub AdvisoriesGHSA-q2hq-v4x4-w3r5 No score

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro ...

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
GHSA-q2hq-v4x4-w3r5
Weakness
CWE-787
Updated
2026-11-02
OSV No score

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
CVE-2011-1782
Updated
2026-11-02
OSVDEBIAN-CVE-2011-1782 No score

Heap-based buffer overflow in the read_channel_data function in file-psp.c in the Paint Shop Pro (PSP) plugin in GIMP 2.6.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a PSP_COMP_RLE (aka RLE compression) image file that begins a long run count at the end of the image. NOTE: some of these details are obtained from third party information. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-4543.

Record
DEBIAN-CVE-2011-1782
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
gimp
Debian:12
before 2.6.11-3
2.6.11-3
gimp
Debian:13
before 2.6.11-3
2.6.11-3
gimp
Debian:14
before 2.6.11-3
2.6.11-3
gimp
Debian:6.0
before 2.6.10-1+squeeze3, plus listed versions
2.6.10-12.6.10-1+squeeze1
2.6.10-1+squeeze3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-1782 is a high vulnerability (CVSS 7.5) in Gimp, published July 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.43%, the 88th percentile. Fixed in gimp 2.6.11-3.

References

MoveEnter Open