Every CVE Search/ Get API key

CVE-2011-2211

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the...

7.2 HighFix available

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the Alpha platform uses an incorrect pointer, which allows local users to gain privileges by writing a certain integer value to kernel memory.

Exploit likelihood

0.48%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the Alpha platform uses an incorrect pointer, which allows local users to gain privileges by writing a certain integer value to kernel memory.

Record
CVE-2011-2211
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the Alpha platform uses an incorrect pointer, which allows local users to gain privileges by writing a certain integer value to kernel memory.

Record
CVE-2011-2211
Updated
2026-11-02
EUVDEUVD-2011-2200 No score

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the Alpha platform uses an incorrect pointer, which allows local users to gain privileges by writing a certain integer value to kernel memory.

Record
EUVD-2011-2200
Updated
2026-11-03
GitHub AdvisoriesGHSA-6cqh-9qmc-hpcr No score

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the...

The osf_wait4 function in arch/alpha/kernel/osf_sys.c in the Linux kernel before 2.6.39.4 on the Alpha platform uses an incorrect pointer, which allows local users to gain privileges by writing a certain integer value to kernel memory.

Record
GHSA-6cqh-9qmc-hpcr
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
linux-2.6
Debian:5.0
before 2.6.26-26lenny4, plus listed versions
2.6.26-132.6.26-13lenny22.6.26-13lenny2~bpo40+12.6.26-142.6.26-15
Show 35 moreShow less
2.6.26-15lenny12.6.26-15lenny22.6.26-15lenny32.6.26-15~bpo40+12.6.26-15~bpo40+22.6.26-162.6.26-172.6.26-17lenny12.6.26-17lenny22.6.26-17lenny2~bpo40+12.6.26-17~bpo40+12.6.26-182.6.26-192.6.26-19lenny12.6.26-19lenny22.6.26-19~bpo40+12.6.26-202.6.26-20~bpo40+12.6.26-212.6.26-21lenny12.6.26-21lenny22.6.26-21lenny32.6.26-21lenny42.6.26-21~bpo40+12.6.26-222.6.26-22lenny12.6.26-232.6.26-242.6.26-24lenny12.6.26-252.6.26-25lenny12.6.26-262.6.26-26lenny12.6.26-26lenny22.6.26-26lenny3
2.6.26-26lenny4

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2211 is a high vulnerability (CVSS 7.2) in Linux Kernel, published September 22, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.48%, the 41st percentile. Fixed in linux-2.6 2.6.26-26lenny4.

References

MoveEnter Open