Every CVE Search/ Get API key

CVE-2011-2489

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow...

7.2 High

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow local users to gain privileges via a crafted command line.

Exploit likelihood

0.53%Down 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.2

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow local users to gain privileges via a crafted command line.

Record
CVE-2011-2489
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-189
Updated
2026-11-02
CVE List No score

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow local users to gain privileges via a crafted command line.

Record
CVE-2011-2489
Updated
2026-11-02
EUVDEUVD-2011-2476 No score

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow local users to gain privileges via a crafted command line.

Record
EUVD-2011-2476
Updated
2026-11-03
GitHub AdvisoriesGHSA-w8hp-2828-m4h2 No score

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow...

Multiple off-by-one errors in opiesu.c in opiesu in OPIE 2.4.1-test1 and earlier might allow local users to gain privileges via a crafted command line.

Record
GHSA-w8hp-2828-m4h2
Updated
2026-11-02
OSVopenSUSE-SU-2024:10550-1 No score

opie-2.4-726.12 on GA media

These are all security issues fixed in the opie-2.4-726.12 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10550-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
opie
Debian:6.0
From an advisory covering 2 CVEs
before 2.32.dfsg.1-0.2+squeeze1, plus listed versions
2.32.dfsg.1-0.2
2.32.dfsg.1-0.2+squeeze1
opie
Debian:5.0
From an advisory covering 2 CVEs
before 2.32-10.2+lenny2, plus listed versions
2.32-10.22.32-10.2+lenny1
2.32-10.2+lenny2
opie
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 2.4-726.12
2.4-726.12

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2489 is a high vulnerability (CVSS 7.2) in Nrl Opie, published July 21, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.53%, the 45th percentile. No source names a fixed version.

References

Show 9 moreShow less
MoveEnter Open