Every CVE Search/ Get API key

CVE-2011-2505

phpMyAdmin remote variable manipulation

6.4 MediumPublic exploitFix available

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Exploit likelihood

12.9%Up 8.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.4

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
CVE-2011-2505
CVSS 2.0
6.4 MediumAV:N/AC:L/Au:N/C:N/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
CVE-2011-2505
Updated
2026-11-02
EUVDEUVD-2022-5408 No score

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
EUVD-2022-5408
Updated
2026-11-03
GitHub AdvisoriesGHSA-vqcm-r62w-w437 No score

phpMyAdmin remote variable manipulation

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
GHSA-vqcm-r62w-w437
Weakness
CWE-94
Updated
2026-11-02
OSV No score

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
CVE-2011-2505
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2505 No score

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
DEBIAN-CVE-2011-2505
Updated
2026-11-02
OSVGHSA-vqcm-r62w-w437 No score

phpMyAdmin remote variable manipulation

libraries/auth/swekey/swekey.auth.lib.php in the Swekey authentication feature in phpMyAdmin 3.x before 3.3.10.2 and 3.4.x before 3.4.3.1 assigns values to arbitrary parameters referenced in the query string, which allows remote attackers to modify the SESSION superglobal array via a crafted request, related to a "remote variable manipulation vulnerability."

Record
GHSA-vqcm-r62w-w437
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
3.0 up to 3.3.10.2
3.3.10.2
phpmyadmin/phpmyadmin
Packagist
3.4 up to 3.4.3.1
3.4.3.1
phpmyadmin
Debian:12
before 4:3.4.3.1-1
4:3.4.3.1-1
phpmyadmin
Debian:13
before 4:3.4.3.1-1
4:3.4.3.1-1
phpmyadmin
Debian:14
before 4:3.4.3.1-1
4:3.4.3.1-1
phpmyadmin
Debian:6.0
before 4:3.3.7-6, plus listed versions
4:3.3.7-34:3.3.7-5
4:3.3.7-6
phpmyadmin
Debian:5.0
before 4:2.11.8.1-5+lenny9, plus listed versions
4:2.11.8.1-54:2.11.8.1-5+lenny14:2.11.8.1-5+lenny34:2.11.8.1-5+lenny44:2.11.8.1-5+lenny54:2.11.8.1-5+lenny64:2.11.8.1-5+lenny74:2.11.8.1-5+lenny8
4:2.11.8.1-5+lenny9

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBphpMyAdmin3 (pma3) - Remote Code Execution2011-07-08
Exploit-DBphpMyAdmin 3.x - Swekey Remote Code Injection2011-07-09

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2505 is a medium vulnerability (CVSS 6.4) in Phpmyadmin, published July 14, 2011. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 12.9%, the 96th percentile. Fixed in phpmyadmin/phpmyadmin 3.3.10.2.

References

Show 23 moreShow less
MoveEnter Open