Every CVE Search/ Get API key

CVE-2011-2532

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote...

5.0 MediumFix available

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Exploit likelihood

1.45%Up 0.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
CVE-2011-2532
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-399
Updated
2026-11-02
CVE List No score

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
CVE-2011-2532
Updated
2026-11-02
EUVDEUVD-2011-2515 No score

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
EUVD-2011-2515
Updated
2026-11-03
GitHub AdvisoriesGHSA-mq6h-jh39-cjg8 No score

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote...

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
GHSA-mq6h-jh39-cjg8
Updated
2026-11-02
OSV No score

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
CVE-2011-2532
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2532 No score

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Record
DEBIAN-CVE-2011-2532
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
prosody
Debian:12
before 0.8.1-1
0.8.1-1
prosody
Debian:13
before 0.8.1-1
0.8.1-1
prosody
Debian:14
before 0.8.1-1
0.8.1-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2532 is a medium vulnerability (CVSS 5.0) in Prosody, published June 22, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in prosody 0.8.1-1.

References

MoveEnter Open