Every CVE Search/ Get API key

CVE-2011-2685

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3...

9.3 HighFix available

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Exploit likelihood

7.04%Down 0.5 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
CVE-2011-2685
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
CVE-2011-2685
Updated
2026-11-02
EUVDEUVD-2011-2667 No score

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
EUVD-2011-2667
Updated
2026-11-03
GitHub AdvisoriesGHSA-6mj6-f4j4-fwcx No score

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3...

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
GHSA-6mj6-f4j4-fwcx
Weakness
CWE-119
Updated
2026-11-02
OSV No score

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
CVE-2011-2685
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2685 No score

Stack-based buffer overflow in the Lotus Word Pro import filter in LibreOffice before 3.3.3 allows remote attackers to execute arbitrary code via a crafted .lwp file.

Record
DEBIAN-CVE-2011-2685
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libreoffice
Debian:12
before 1:3.3.3-1
1:3.3.3-1
libreoffice
Debian:13
before 1:3.3.3-1
1:3.3.3-1
libreoffice
Debian:14
before 1:3.3.3-1
1:3.3.3-1
openoffice.org
Debian:6.0
before 1:3.2.1-11+squeeze3, plus listed versions
1:3.2.1-11+squeeze2
1:3.2.1-11+squeeze3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2685 is a high vulnerability (CVSS 9.3) in Libreoffice, published July 7, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 7.04%, the 94th percentile. Fixed in libreoffice 1:3.3.3-1.

References

Show 4 moreShow less
MoveEnter Open