Every CVE Search/ Get API key

CVE-2011-2697

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to...

6.8 MediumFix available

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Exploit likelihood

10.8%Down 23.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
CVE-2011-2697
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-20
Updated
2026-11-02
CVE List No score

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
CVE-2011-2697
Updated
2026-11-02
EUVDEUVD-2011-2678 No score

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
EUVD-2011-2678
Updated
2026-11-03
GitHub AdvisoriesGHSA-fwm5-c4jq-p4wv No score

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to...

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
GHSA-fwm5-c4jq-p4wv
Weakness
CWE-20
Updated
2026-11-02
OSV No score

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
CVE-2011-2697
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2697 No score

foomatic-rip-hplip in HP Linux Imaging and Printing (HPLIP) 3.11.5 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file.

Record
DEBIAN-CVE-2011-2697
Updated
2026-11-02
OSVopenSUSE-SU-2024:10083-1 No score

hplip-3.16.10-1.1 on GA media

These are all security issues fixed in the hplip-3.16.10-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10083-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
foomatic-filters
Debian:12
before 4.0
4.0
foomatic-filters
Debian:13
before 4.0
4.0
foomatic-filters
Debian:14
before 4.0
4.0
hplip
Debian:12
before 3.10.6-2
3.10.6-2
hplip
Debian:13
before 3.10.6-2
3.10.6-2
foomatic-filters
Debian:6.0
before 4.0.5-6+squeeze1, plus listed versions
4.0.5-6
4.0.5-6+squeeze1
foomatic-filters
Debian:5.0
before 3.0.2-20080211-3.2+lenny1, plus listed versions
3.0.2-20080211-3.2
3.0.2-20080211-3.2+lenny1
foomatic
Red Hat:enterprise_linux:4::as
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic-debuginfo
Red Hat:enterprise_linux:4::as
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic
Red Hat:enterprise_linux:4::desktop
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
Show 10 moreShow less
Affected packages
PackageAffectedFixed
foomatic-debuginfo
Red Hat:enterprise_linux:4::desktop
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic
Red Hat:enterprise_linux:4::es
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic-debuginfo
Red Hat:enterprise_linux:4::es
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic
Red Hat:enterprise_linux:4::ws
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic-debuginfo
Red Hat:enterprise_linux:4::ws
before 0:3.0.2-3.2.el4
0:3.0.2-3.2.el4
foomatic
Red Hat:enterprise_linux:5::client
before 0:3.0.2-38.3.el5_7.1
0:3.0.2-38.3.el5_7.1
foomatic-debuginfo
Red Hat:enterprise_linux:5::client
before 0:3.0.2-38.3.el5_7.1
0:3.0.2-38.3.el5_7.1
foomatic
Red Hat:enterprise_linux:5::server
before 0:3.0.2-38.3.el5_7.1
0:3.0.2-38.3.el5_7.1
foomatic-debuginfo
Red Hat:enterprise_linux:5::server
before 0:3.0.2-38.3.el5_7.1
0:3.0.2-38.3.el5_7.1
hplip
openSUSE:Tumbleweed
before 3.16.10-1.1
3.16.10-1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2697 is a medium vulnerability (CVSS 6.8) in Hp Linux Imaging And Printing Project, published July 29, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 10.8%, the 95th percentile. Fixed in foomatic-filters 4.0.

References

Show 20 moreShow less
MoveEnter Open