CVE-2011-2704
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote...
CVE-2011-2704 is a high vulnerability (CVSS 7.5) in Osgeo Mapserver, published July 26, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.22%, the 92nd percentile. Fixed in mapserver 6.0.1-1.
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
Exploit likelihood
What each source reports
NVD Score used
7.5
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
CVE-2011-2704- CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-119
- Updated
- 2026-11-02
CVE List No score
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
CVE-2011-2704- Updated
- 2026-11-02
EUVDEUVD-2011-2685 No score
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
EUVD-2011-2685- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5p55-9x25-v5f2 No score
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote...
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
GHSA-5p55-9x25-v5f2- Weakness
- CWE-119
- Updated
- 2026-11-02
OSV No score
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
CVE-2011-2704- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-2704 No score
Stack-based buffer overflow in MapServer before 4.10.7 and 5.x before 5.6.7 allows remote attackers to execute arbitrary code via vectors related to OGC filter encoding.
- Record
DEBIAN-CVE-2011-2704- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
mapserverDebian:12 |
before 6.0.1-1 | 6.0.1-1 |
mapserverDebian:13 |
before 6.0.1-1 | 6.0.1-1 |
mapserverDebian:14 |
before 6.0.1-1 | 6.0.1-1 |
mapserverDebian:6.0 |
before 5.6.5-2+squeeze2, plus listed versions 5.6.5-2 |
5.6.5-2+squeeze2 |
mapserverDebian:5.0 |
before 5.0.3-3+lenny7, plus listed versions 5.0.3-35.0.3-3+lenny45.0.3-3+lenny5 |
5.0.3-3+lenny7 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
trac.osgeo.org/mapserver/ticket/3903
exchange.xforce.ibmcloud.com/vulnerabilities/68719
secunia.com/advisories/45257
debian.org/security/2011/dsa-2285
bugzilla.redhat.com/show_bug.cgi?id=723293
openwall.com/lists/oss-security/2011/07/19/14