CVE-2011-2771
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers...
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) URI attributes and (2) the External Feed component, as demonstrated by the guid element in an RSS feed.
Exploit likelihood
What each source reports
NVD Score used
4.3
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) URI attributes and (2) the External Feed component, as demonstrated by the guid element in an RSS feed.
- Record
CVE-2011-2771- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) URI attributes and (2) the External Feed component, as demonstrated by the guid element in an RSS feed.
- Record
CVE-2011-2771- Updated
- 2026-11-02
EUVDEUVD-2011-2745 No score
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) URI attributes and (2) the External Feed component, as demonstrated by the guid element in an RSS feed.
- Record
EUVD-2011-2745- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-rg33-jc9v-hm8q No score
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers...
Multiple cross-site scripting (XSS) vulnerabilities in Mahara before 1.4.1 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) URI attributes and (2) the External Feed component, as demonstrated by the guid element in an RSS feed.
- Record
GHSA-rg33-jc9v-hm8q- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
maharaDebian:5.0 From an advisory covering 4 CVEs |
before 1.0.4-4+lenny11, plus listed versions 1.0.4-41.0.4-4+lenny11.0.4-4+lenny101.0.4-4+lenny21.0.4-4+lenny3 Show 5 moreShow less1.0.4-4+lenny41.0.4-4+lenny51.0.4-4+lenny61.0.4-4+lenny71.0.4-4+lenny8 |
1.0.4-4+lenny11 |
maharaDebian:6.0 From an advisory covering 4 CVEs |
before 1.2.6-2+squeeze3, plus listed versions 1.2.6-21.2.6-2+squeeze11.2.6-2+squeeze2 |
1.2.6-2+squeeze3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-2771 is a medium vulnerability (CVSS 4.3) in Mahara, published November 4, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.80%, the 78th percentile. No source names a fixed version.
References
security.debian.org/debian-security/pool/updates/main/m/mahara/mahara_1.2.6-2+squeeze3.debian.tar.gz
launchpad.net/mahara/+milestone/1.4.1
debian.org/security/2011/dsa-2334
bugs.launchpad.net/mahara/+bug/798136
secunia.com/advisories/46719
nvd.nist.gov/vuln/detail/CVE-2011-2771
github.com/advisories/GHSA-rg33-jc9v-hm8q