CVE-2011-2772
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly...
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly validate uploaded image files, which allows remote attackers to cause a denial of service (memory consumption) via a (1) large or (2) invalid image.
Exploit likelihood
What each source reports
NVD Score used
5.0
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly validate uploaded image files, which allows remote attackers to cause a denial of service (memory consumption) via a (1) large or (2) invalid image.
- Record
CVE-2011-2772- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly validate uploaded image files, which allows remote attackers to cause a denial of service (memory consumption) via a (1) large or (2) invalid image.
- Record
CVE-2011-2772- Updated
- 2026-11-02
EUVDEUVD-2011-2746 No score
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly validate uploaded image files, which allows remote attackers to cause a denial of service (memory consumption) via a (1) large or (2) invalid image.
- Record
EUVD-2011-2746- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-32wr-mvch-qw37 No score
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly...
The get_dataroot_image_path function in lib/file.php in Mahara before 1.4.1 does not properly validate uploaded image files, which allows remote attackers to cause a denial of service (memory consumption) via a (1) large or (2) invalid image.
- Record
GHSA-32wr-mvch-qw37- Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
maharaDebian:5.0 From an advisory covering 4 CVEs |
before 1.0.4-4+lenny11, plus listed versions 1.0.4-41.0.4-4+lenny11.0.4-4+lenny101.0.4-4+lenny21.0.4-4+lenny3 Show 5 moreShow less1.0.4-4+lenny41.0.4-4+lenny51.0.4-4+lenny61.0.4-4+lenny71.0.4-4+lenny8 |
1.0.4-4+lenny11 |
maharaDebian:6.0 From an advisory covering 4 CVEs |
before 1.2.6-2+squeeze3, plus listed versions 1.2.6-21.2.6-2+squeeze11.2.6-2+squeeze2 |
1.2.6-2+squeeze3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-2772 is a medium vulnerability (CVSS 5.0) in Mahara, published November 4, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.27%, the 83rd percentile. No source names a fixed version.
References
security.debian.org/debian-security/pool/updates/main/m/mahara/mahara_1.2.6-2+squeeze3.debian.tar.gz
launchpad.net/mahara/+milestone/1.4.1
bugs.launchpad.net/mahara/+bug/784978
debian.org/security/2011/dsa-2334
secunia.com/advisories/46719
nvd.nist.gov/vuln/detail/CVE-2011-2772
github.com/advisories/GHSA-32wr-mvch-qw37