Every CVE Search/ Get API key

CVE-2011-2909

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before...

4.9 MediumFix available

CVE-2011-2909 is a medium vulnerability (CVSS 4.9) in Linux Kernel, published September 8, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.37%, the 30th percentile. Fixed in linux-2.6 2.6.32-35squeeze1.

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before 3.1 allows local users to obtain sensitive information from kernel memory via a copy of a short string.

Exploit likelihood

0.37%Down 0.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.9

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before 3.1 allows local users to obtain sensitive information from kernel memory via a copy of a short string.

Record
CVE-2011-2909
CVSS 2.0
4.9 MediumAV:L/AC:L/Au:N/C:C/I:N/A:N
Weakness
CWE-200
Updated
2026-11-02
CVE List No score

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before 3.1 allows local users to obtain sensitive information from kernel memory via a copy of a short string.

Record
CVE-2011-2909
Updated
2026-11-02
EUVDEUVD-2011-2882 No score

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before 3.1 allows local users to obtain sensitive information from kernel memory via a copy of a short string.

Record
EUVD-2011-2882
Updated
2026-11-03
GitHub AdvisoriesGHSA-8fmr-prqp-6wvj No score

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before...

The do_devinfo_ioctl function in drivers/staging/comedi/comedi_fops.c in the Linux kernel before 3.1 allows local users to obtain sensitive information from kernel memory via a copy of a short string.

Record
GHSA-8fmr-prqp-6wvj
Weakness
CWE-200
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
linux-2.6
Debian:6.0
before 2.6.32-35squeeze1, plus listed versions
2.6.32-302.6.32-30+m68k.52.6.32-312.6.32-31~bpo50+12.6.32-32
Show 5 moreShow less
2.6.32-332.6.32-342.6.32-34squeeze12.6.32-352.6.32-35~bpo50+1
2.6.32-35squeeze1

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open