Every CVE Search/ Get API key

CVE-2011-2964

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to...

6.8 MediumFix available

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Exploit likelihood

4.96%Down 6.3 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
CVE-2011-2964
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
CVE-2011-2964
Updated
2026-11-02
EUVDEUVD-2011-2932 No score

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
EUVD-2011-2932
Updated
2026-11-03
GitHub AdvisoriesGHSA-hc8g-chpw-24wx No score

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to...

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
GHSA-hc8g-chpw-24wx
Weakness
CWE-94
Updated
2026-11-02
OSV No score

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
CVE-2011-2964
Updated
2026-11-02
OSVDEBIAN-CVE-2011-2964 No score

foomaticrip.c in foomatic-rip in foomatic-filters in Foomatic 4.0.6 allows remote attackers to execute arbitrary code via a crafted *FoomaticRIPCommandLine field in a .ppd file, a different vulnerability than CVE-2011-2697.

Record
DEBIAN-CVE-2011-2964
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
foomatic-filters
Debian:12
before 4.0.9-1
4.0.9-1
foomatic-filters
Debian:13
before 4.0.9-1
4.0.9-1
foomatic-filters
Debian:14
before 4.0.9-1
4.0.9-1
foomatic-filters
Debian:6.0
before 4.0.5-6+squeeze1, plus listed versions
4.0.5-6
4.0.5-6+squeeze1
foomatic-filters
Debian:5.0
before 3.0.2-20080211-3.2+lenny1, plus listed versions
3.0.2-20080211-3.2
3.0.2-20080211-3.2+lenny1
foomatic
Red Hat:enterprise_linux:6::server
before 0:4.0.4-1.el6_1.1
0:4.0.4-1.el6_1.1
foomatic-debuginfo
Red Hat:enterprise_linux:6::server
before 0:4.0.4-1.el6_1.1
0:4.0.4-1.el6_1.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-2964 is a medium vulnerability (CVSS 6.8) in Linuxfoundation Foomatic, published July 29, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.96%, the 92nd percentile. Fixed in foomatic-filters 4.0.9-1.

References

Show 15 moreShow less
MoveEnter Open