Every CVE Search/ Get API key

CVE-2011-3170

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly...

5.1 MediumFix available

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Exploit likelihood

3.95%Down 5.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.1

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
CVE-2011-3170
CVSS 2.0
5.1 MediumAV:N/AC:H/Au:N/C:P/I:P/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
CVE-2011-3170
Updated
2026-11-02
EUVDEUVD-2011-3137 No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
EUVD-2011-3137
Updated
2026-11-03
GitHub AdvisoriesGHSA-gq38-xj7p-vcm8 No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly...

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
GHSA-gq38-xj7p-vcm8
Weakness
CWE-119
Updated
2026-11-02
OSV No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
CVE-2011-3170
Updated
2026-11-02
OSVDEBIAN-CVE-2011-3170 No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
DEBIAN-CVE-2011-3170
Updated
2026-11-02
OSVUBUNTU-CVE-2011-3170 No score

The gif_read_lzw function in filter/image-gif.c in CUPS 1.4.8 and earlier does not properly handle the first code word in an LZW stream, which allows remote attackers to trigger a heap-based buffer overflow, and possibly execute arbitrary code, via a crafted stream, a different vulnerability than CVE-2011-2896.

Record
UBUNTU-CVE-2011-3170
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
cups
Debian:12
before 1.5.0-8
1.5.0-8
cups
Debian:13
before 1.5.0-8
1.5.0-8
cups
Debian:14
before 1.5.0-8
1.5.0-8
cups
Debian:6.0
From an advisory covering 2 CVEs
before 1.4.4-7+squeeze1, plus listed versions
1.4.4-7
1.4.4-7+squeeze1
cups
Debian:5.0
From an advisory covering 2 CVEs
before 1.3.8-1+lenny10, plus listed versions
1.3.8-1+lenny61.3.8-1+lenny71.3.8-1+lenny81.3.8-1+lenny91.3.8-1lenny4.11.3.8-1lenny5
1.3.8-1+lenny10
swi-prolog
Ubuntu:16.04:LTS
All versions, plus listed versions
7.2.0-27.2.0-37.2.3-2
None known
swi-prolog
Ubuntu:18.04:LTS
All versions, plus listed versions
7.4.2+dfsg-27.6.1+dfsg-27.6.1+dfsg-37.6.2+dfsg-17.6.4+dfsg-1build1
None known
swi-prolog
Ubuntu:20.04:LTS
All versions, plus listed versions
7.6.4+dfsg-2ubuntu2
None known
swi-prolog
Ubuntu:22.04:LTS
All versions, plus listed versions
8.2.4+dfsg-1ubuntu18.4.2+dfsg-2ubuntu1
None known
swi-prolog
Ubuntu:24.04:LTS
All versions, plus listed versions
9.0.4+dfsg-2ubuntu19.0.4+dfsg-3ubuntu19.0.4+dfsg-3.1ubuntu39.0.4+dfsg-3.1ubuntu4
None known
swi-prolog
Ubuntu:25.10
All versions, plus listed versions
9.0.4+dfsg-3.1ubuntu49.2.9+dfsg-1
None known
swi-prolog
Ubuntu:26.10
All versions, plus listed versions
9.2.9+dfsg-1.1build19.2.9+dfsg-1.1ubuntu19.2.9+dfsg-1.1ubuntu3
None known
swi-prolog
Ubuntu:26.04:LTS
All versions, plus listed versions
9.2.9+dfsg-19.2.9+dfsg-1.19.2.9+dfsg-1.1build1
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-3170 is a medium vulnerability (CVSS 5.1) in Apple Cups, published August 19, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.95%, the 90th percentile. Fixed in cups 1.5.0-8.

References

Show 12 moreShow less
MoveEnter Open