Every CVE Search/ Get API key

CVE-2011-3504

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which...

9.3 HighFix available

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Exploit likelihood

5.89%Down 4.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 9.3

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
CVE-2011-3504
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
CVE-2011-3504
Updated
2026-11-02
EUVDEUVD-2011-3467 No score

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
EUVD-2011-3467
Updated
2026-11-03
GitHub AdvisoriesGHSA-78h7-gxcg-7x5r No score

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which...

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
GHSA-78h7-gxcg-7x5r
Weakness
CWE-94
Updated
2026-11-02
OSV No score

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
CVE-2011-3504
Updated
2026-11-02
OSVDEBIAN-CVE-2011-3504 No score

The Matroska format decoder in FFmpeg before 0.8.3 does not properly allocate memory, which allows remote attackers to execute arbitrary code via a crafted file.

Record
DEBIAN-CVE-2011-3504
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
ffmpeg
Debian:12
before 7:2.4.1-1
7:2.4.1-1
ffmpeg
Debian:13
before 7:2.4.1-1
7:2.4.1-1
ffmpeg
Debian:14
before 7:2.4.1-1
7:2.4.1-1
ffmpeg
Debian:6.0
before 4:0.5.5-1, plus listed versions
4:0.5.2-64:0.5.4-1
4:0.5.5-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-3504 is a high vulnerability (CVSS 9.3) in Ffmpeg, published September 29, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.89%, the 93rd percentile. Fixed in ffmpeg 7:2.4.1-1.

References

Show 7 moreShow less
MoveEnter Open