CVE-2011-3591
phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
CVE-2011-3591 is a low vulnerability (CVSS 3.5) in Phpmyadmin, published December 26, 2014. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.45%, the 73rd percentile. Fixed in phpmyadmin/phpmyadmin 3.4.5.
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
Exploit likelihood
What each source reports
NVD Score used
3.5
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
CVE-2011-3591- CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
CVE-2011-3591- Updated
- 2026-11-02
EUVDEUVD-2022-2222 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
EUVD-2022-2222- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3p87-w3c5-27gf No score
phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
GHSA-3p87-w3c5-27gf- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
CVE-2011-3591- Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-3591 No score
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
DEBIAN-CVE-2011-3591- Updated
- 2026-11-02
OSVGHSA-3p87-w3c5-27gf No score
phpMyAdmin Multiple XSS Vulnerabilities After Inline Editing and Save
Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin 3.4.x before 3.4.5 allow remote authenticated users to inject arbitrary web script or HTML via a crafted row that triggers an improperly constructed confirmation message after inline-editing and save operations, related to (1) js/functions.js and (2) js/tbl_structure.js.
- Record
GHSA-3p87-w3c5-27gf- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
phpmyadmin/phpmyadminPackagist |
3.4.0 up to 3.4.5 | 3.4.5 |
phpmyadminDebian:12 |
before 4:3.4.5-1 | 4:3.4.5-1 |
phpmyadminDebian:13 |
before 4:3.4.5-1 | 4:3.4.5-1 |
phpmyadminDebian:14 |
before 4:3.4.5-1 | 4:3.4.5-1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/phpmyadmin/phpmyadmin/commit/bda213c58aec44925be661acb0e76c19483ea170
openwall.com/lists/oss-security/2011/09/30/8
phpmyadmin.net/home_page/security/PMASA-2011-14.php
bugzilla.redhat.com/show_bug.cgi?id=738681
nvd.nist.gov/vuln/detail/CVE-2011-3591
github.com/advisories/GHSA-3p87-w3c5-27gf
security-tracker.debian.org/tracker/CVE-2011-3591
github.com/phpmyadmin/composer