Every CVE Search/ Get API key

CVE-2011-4133

Moodle vulnerable to Cross-Site Request Forgery

6.8 MediumFix available

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Exploit likelihood

1.01%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.8

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Record
CVE-2011-4133
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-352
Updated
2026-11-02
CVE List No score

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Record
CVE-2011-4133
Updated
2026-11-02
EUVDEUVD-2011-4081 No score

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Record
EUVD-2011-4081
Updated
2026-11-03
GitHub AdvisoriesGHSA-7cvw-wrj9-q5fp 6.6

Moodle vulnerable to Cross-Site Request Forgery

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Record
GHSA-7cvw-wrj9-q5fp
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-352
Updated
2026-11-02
OSVGHSA-7cvw-wrj9-q5fp 6.6

Moodle vulnerable to Cross-Site Request Forgery

Cross-site request forgery (CSRF) vulnerability in Moodle 1.9.x before 1.9.11 allows remote attackers to hijack the authentication of unspecified victims for requests that modify an RSS feed in an RSS block.

Record
GHSA-7cvw-wrj9-q5fp
CVSS 4.0
6.6 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:U
Weakness
CWE-352
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
1.9.0 up to 1.9.11
1.9.11
moodle
Debian:6.0
From an advisory covering 6 CVEs
before 1.9.9.dfsg2-2.1+squeeze1, plus listed versions
1.9.9.dfsg2-2.1
1.9.9.dfsg2-2.1+squeeze1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4133 is a medium vulnerability (CVSS 6.8) in Moodle, published June 16, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.01%, the 63rd percentile. Fixed in moodle/moodle 1.9.11.

References

MoveEnter Open