CVE-2011-4278
Moodle XSS In Tag Autocomplete functionality
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2011-4278- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
CVE-2011-4278- Updated
- 2026-11-02
EUVDEUVD-2022-2723 No score
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
EUVD-2022-2723- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6656-6qwx-4c2m No score
Moodle XSS In Tag Autocomplete functionality
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-6656-6qwx-4c2m- Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-6656-6qwx-4c2m No score
Moodle XSS In Tag Autocomplete functionality
Cross-site scripting (XSS) vulnerability in the tag autocomplete functionality in Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
- Record
GHSA-6656-6qwx-4c2m- Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.0 up to 2.0.2 | 2.0.2 |
moodle/moodlePackagist |
before 1.9.11 | 1.9.11 |
moodleDebian:6.0 From an advisory covering 6 CVEs |
before 1.9.9.dfsg2-2.1+squeeze1, plus listed versions 1.9.9.dfsg2-2.1 |
1.9.9.dfsg2-2.1+squeeze1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4278 is a medium vulnerability (CVSS 4.3) in Moodle, published June 16, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 79th percentile. Fixed in moodle/moodle 2.0.2.
References
openwall.com/lists/oss-security/2011/11/14/1
moodle.org/mod/forum/discuss.php?d=170003
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=fd29b2ad1c20906da00d7e523f39bc8a0358a65b
nvd.nist.gov/vuln/detail/CVE-2011-4278
git.moodle.org/gw?p=moodle.git;a=commit;h=fd29b2ad1c20906da00d7e523f39bc8a0358a65b
github.com/moodle/moodle/commit/34b93e39a64a68e4a676b93ccf2bd87a1d3b5ef8
github.com/moodle/moodle/commit/fd29b2ad1c20906da00d7e523f39bc8a0358a65b
github.com/advisories/GHSA-6656-6qwx-4c2m
github.com/moodle/moodle