Every CVE Search/ Get API key

CVE-2011-4280

Moodle vulnerable to XSS via bundled spikephpcoverage library

4.3 MediumPublic exploitFix available

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Exploit likelihood

3.62%Up 1.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2011-4280
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
CVE-2011-4280
Updated
2026-11-02
EUVDEUVD-2022-4646 No score

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
EUVD-2022-4646
Updated
2026-11-03
GitHub AdvisoriesGHSA-mx5g-3vxh-rgm8 No score

Moodle vulnerable to XSS via bundled spikephpcoverage library

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-mx5g-3vxh-rgm8
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-mx5g-3vxh-rgm8 No score

Moodle vulnerable to XSS via bundled spikephpcoverage library

Cross-site scripting (XSS) vulnerability in the Spike PHPCoverage (aka spikephpcoverage) library, as used in Moodle 2.0.x before 2.0.2 and other products, allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

Record
GHSA-mx5g-3vxh-rgm8
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.0 up to 2.0.2
2.0.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBMoodle 2.0.1 - 'PHPCOVERAGE_HOME' Cross-Site Scripting2011-02-01

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4280 is a medium vulnerability (CVSS 4.3) in Moodle, published July 16, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 3.62%, the 89th percentile. Fixed in moodle/moodle 2.0.2.

References

MoveEnter Open