CVE-2011-4283
Moodle allows remote attackers to obtain sensitive information
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
Exploit likelihood
What each source reports
NVD Score used
5.0
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
- Record
CVE-2011-4283- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List No score
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
- Record
CVE-2011-4283- Updated
- 2026-11-02
EUVDEUVD-2011-4223 No score
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
- Record
EUVD-2011-4223- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m3xp-4hf3-qfpp
6.6
Moodle allows remote attackers to obtain sensitive information
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
- Record
GHSA-m3xp-4hf3-qfpp- CVSS 4.0
- 6.6 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-m3xp-4hf3-qfpp
6.6
Moodle allows remote attackers to obtain sensitive information
Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.
- Record
GHSA-m3xp-4hf3-qfpp- CVSS 4.0
- 6.6 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
1.9.0 up to 1.9.11 | 1.9.11 |
moodle/moodlePackagist |
2.0.0 up to 2.0.2 | 2.0.2 |
moodleDebian:6.0 From an advisory covering 6 CVEs |
before 1.9.9.dfsg2-2.1+squeeze1, plus listed versions 1.9.9.dfsg2-2.1 |
1.9.9.dfsg2-2.1+squeeze1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4283 is a medium vulnerability (CVSS 5.0) in Moodle, published June 16, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in moodle/moodle 1.9.11.
References
openwall.com/lists/oss-security/2011/11/14/1
moodle.org/mod/forum/discuss.php?d=170009
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=6fde0dac702b3d0954bd1c34d427944e9cd89ae6
nvd.nist.gov/vuln/detail/CVE-2011-4283
git.moodle.org/gw?p=moodle.git;a=commit;h=6fde0dac702b3d0954bd1c34d427944e9cd89ae6
github.com/advisories/GHSA-m3xp-4hf3-qfpp
github.com/moodle/moodle