Every CVE Search/ Get API key

CVE-2011-4285

Moodle Incorrect Default Settings

5.5 MediumFix available

CVE-2011-4285 is a medium vulnerability (CVSS 5.5) in Moodle, published July 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.91%, the 79th percentile. Fixed in moodle/moodle 2.0.2.

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Exploit likelihood

1.91%Up 0.8 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Record
CVE-2011-4285
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:N/I:P/A:P
Weakness
CWE-264
Updated
2026-11-02
CVE List No score

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Record
CVE-2011-4285
Updated
2026-11-02
EUVDEUVD-2022-3244 No score

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Record
EUVD-2022-3244
Updated
2026-11-03
GitHub AdvisoriesGHSA-8vjj-wf73-w882 No score

Moodle Incorrect Default Settings

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Record
GHSA-8vjj-wf73-w882
Weakness
CWE-276
Updated
2026-11-02
OSVGHSA-8vjj-wf73-w882 No score

Moodle Incorrect Default Settings

The default configuration of Moodle 2.0.x before 2.0.2 has an incorrect setting of the moodle/course:delete capability, which allows remote authenticated users to delete arbitrary courses by leveraging the teacher role.

Record
GHSA-8vjj-wf73-w882
Weakness
CWE-276
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.0 up to 2.0.2
2.0.2

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open