Every CVE Search/ Get API key

CVE-2011-4291

Moodle allows remote authenticated users to cause a denial of service (invalid database records)

4.0 MediumFix available

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Exploit likelihood

1.92%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Record
CVE-2011-4291
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Record
CVE-2011-4291
Updated
2026-11-02
EUVDEUVD-2011-4230 No score

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Record
EUVD-2011-4230
Updated
2026-11-03
GitHub AdvisoriesGHSA-m2pf-4pf8-45j2 4.9

Moodle allows remote authenticated users to cause a denial of service (invalid database records)

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Record
GHSA-m2pf-4pf8-45j2
CVSS 4.0
4.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02
OSVGHSA-m2pf-4pf8-45j2 4.9

Moodle allows remote authenticated users to cause a denial of service (invalid database records)

Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted ratings operations.

Record
GHSA-m2pf-4pf8-45j2
CVSS 4.0
4.9 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U
Weakness
CWE-20
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.0.0 up to 2.0.3
2.0.3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4291 is a medium vulnerability (CVSS 4.0) in Moodle, published July 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 79th percentile. Fixed in moodle/moodle 2.0.3.

References

MoveEnter Open