CVE-2011-4292
Moodle allows remote authenticated users to cause a denial of service (invalid database records)
CVE-2011-4292 is a medium vulnerability (CVSS 4.0) in Moodle, published July 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in moodle/moodle 2.0.3.
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
Exploit likelihood
What each source reports
NVD Score used
4.0
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
- Record
CVE-2011-4292- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:N/A:P - Weakness
- CWE-89
- Updated
- 2026-11-02
CVE List No score
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
- Record
CVE-2011-4292- Updated
- 2026-11-02
EUVDEUVD-2011-4231 No score
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
- Record
EUVD-2011-4231- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fhgh-fjh9-vq62
4.9
Moodle allows remote authenticated users to cause a denial of service (invalid database records)
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
- Record
GHSA-fhgh-fjh9-vq62- CVSS 4.0
- 4.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-89
- Updated
- 2026-11-02
OSVGHSA-fhgh-fjh9-vq62
4.9
Moodle allows remote authenticated users to cause a denial of service (invalid database records)
Moodle 2.0.x before 2.0.3 allows remote authenticated users to cause a denial of service (invalid database records) via a series of crafted comments operations.
- Record
GHSA-fhgh-fjh9-vq62- CVSS 4.0
- 4.9 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U - Weakness
- CWE-89
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.0.0 up to 2.0.3 | 2.0.3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
openwall.com/lists/oss-security/2011/11/14/1
moodle.org/mod/forum/discuss.php?d=175594
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=acb4688d29a7cc028803ee3d81edc7f1b6515c64
nvd.nist.gov/vuln/detail/CVE-2011-4292
git.moodle.org/gw?p=moodle.git;a=commit;h=acb4688d29a7cc028803ee3d81edc7f1b6515c64
github.com/advisories/GHSA-fhgh-fjh9-vq62
git.moodle.org