CVE-2011-4300
Moodle does not properly restrict access to category and course data
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
Exploit likelihood
What each source reports
NVD Score used
5.0
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
- Record
CVE-2011-4300- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
- Record
CVE-2011-4300- Updated
- 2026-11-02
EUVDEUVD-2022-3416 No score
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
- Record
EUVD-2022-3416- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9p54-pc88-36c4 No score
Moodle does not properly restrict access to category and course data
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
- Record
GHSA-9p54-pc88-36c4- Weakness
- CWE-284
- Updated
- 2026-11-02
OSVGHSA-9p54-pc88-36c4 No score
Moodle does not properly restrict access to category and course data
The file_browser component in Moodle 2.0.x before 2.0.5 and 2.1.x before 2.1.2 does not properly restrict access to category and course data, which allows remote attackers to obtain potentially sensitive information via a request for a file.
- Record
GHSA-9p54-pc88-36c4- Weakness
- CWE-284
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.1 up to 2.1.2 | 2.1.2 |
moodle/moodlePackagist |
2.0.0 up to 2.0.5 | 2.0.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4300 is a medium vulnerability (CVSS 5.0) in Moodle, published July 11, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in moodle/moodle 2.1.2.
References
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=f6b07c4da54a9db24723beb147e8a19a3d487e00
moodle.org/mod/forum/discuss.php?d=188311
bugzilla.redhat.com/show_bug.cgi?id=747444
nvd.nist.gov/vuln/detail/CVE-2011-4300
git.moodle.org/gw?p=moodle.git;a=commit;h=f6b07c4da54a9db24723beb147e8a19a3d487e00
github.com/moodle/moodle/commit/6f7c43c7de8f62cd53a7f3b54ad5325cd109c1be