Every CVE Search/ Get API key

CVE-2011-4301

Moodle Allows Modification of Constants

5.0 MediumFix available

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Exploit likelihood

2.10%Up 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Record
CVE-2011-4301
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Record
CVE-2011-4301
Updated
2026-11-02
EUVDEUVD-2022-4333 No score

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Record
EUVD-2022-4333
Updated
2026-11-03
GitHub AdvisoriesGHSA-jcrj-gmr6-p5j8 No score

Moodle Allows Modification of Constants

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Record
GHSA-jcrj-gmr6-p5j8
Weakness
CWE-471
Updated
2026-11-02
OSVGHSA-jcrj-gmr6-p5j8 No score

Moodle Allows Modification of Constants

The MoodleQuickForm class in the Forms Library in lib/formslib.php in Moodle 1.9.x before 1.9.14, 2.0.x before 2.0.5, and 2.1.x before 2.1.2 does not recognize Forms API setConstant operations, which allows remote attackers to submit unexpected form content by modifying the values of constant fields.

Record
GHSA-jcrj-gmr6-p5j8
Weakness
CWE-471
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 1.9.14
1.9.14
moodle/moodle
Packagist
2.0 up to 2.0.5
2.0.5
moodle/moodle
Packagist
2.1 up to 2.1.2
2.1.2
moodle
Debian:6.0
From an advisory covering 5 CVEs
before 1.9.9.dfsg2-2.1+squeeze2, plus listed versions
1.9.9.dfsg2-2.11.9.9.dfsg2-2.1+squeeze1
1.9.9.dfsg2-2.1+squeeze2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4301 is a medium vulnerability (CVSS 5.0) in Moodle, published November 7, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.10%, the 81st percentile. Fixed in moodle/moodle 1.9.14.

References

Show 5 moreShow less
MoveEnter Open