Every CVE Search/ Get API key

CVE-2011-4306

Moodle XSS Vulnerability

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Exploit likelihood

1.83%Up 0.7 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Record
CVE-2011-4306
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Record
CVE-2011-4306
Updated
2026-11-02
EUVDEUVD-2022-5120 No score

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Record
EUVD-2022-5120
Updated
2026-11-03
GitHub AdvisoriesGHSA-r729-mx2r-j26j No score

Moodle XSS Vulnerability

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Record
GHSA-r729-mx2r-j26j
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-r729-mx2r-j26j No score

Moodle XSS Vulnerability

Cross-site scripting (XSS) vulnerability in course/editsection.html in Moodle 1.9.x before 1.9.14 allows remote authenticated users to inject arbitrary web script or HTML via crafted data.

Record
GHSA-r729-mx2r-j26j
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
before 1.9.14
1.9.14
moodle
Debian:6.0
From an advisory covering 5 CVEs
before 1.9.9.dfsg2-2.1+squeeze2, plus listed versions
1.9.9.dfsg2-2.11.9.9.dfsg2-2.1+squeeze1
1.9.9.dfsg2-2.1+squeeze2

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4306 is a medium vulnerability (CVSS 4.3) in Moodle, published November 7, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.83%, the 79th percentile. Fixed in moodle/moodle 1.9.14.

References

MoveEnter Open