Every CVE Search/ Get API key

CVE-2011-4319

Cross-site Scripting vulnerability in i18n translations helper method

4.3 MediumFix available

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Exploit likelihood

1.58%Down 0.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Record
CVE-2011-4319
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Record
CVE-2011-4319
Updated
2026-11-02
EUVDEUVD-2017-0337 No score

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Record
EUVD-2017-0337
Updated
2026-11-03
GitHub AdvisoriesGHSA-xxr8-833v-c7wc No score

Cross-site Scripting vulnerability in i18n translations helper method

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Record
GHSA-xxr8-833v-c7wc
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-xxr8-833v-c7wc No score

Cross-site Scripting vulnerability in i18n translations helper method

Cross-site scripting (XSS) vulnerability in the i18n translations helper method in Ruby on Rails 3.0.x before 3.0.11 and 3.1.x before 3.1.2, and the rails_xss plugin in Ruby on Rails 2.3.x, allows remote attackers to inject arbitrary web script or HTML via vectors related to a translations string whose name ends with an "html" substring.

Record
GHSA-xxr8-833v-c7wc
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
actionpack
RubyGems
3.0.0 up to 3.0.11
3.0.11
actionpack
RubyGems
3.1.0 up to 3.1.2
3.1.2
actionpack
RubyGems
3.0.0 up to 3.0.11, plus listed versions
3.0.13.0.103.0.10.rc13.0.23.0.3
Show 19 moreShow less
3.0.43.0.4.rc13.0.53.0.5.rc13.0.63.0.6.rc13.0.6.rc23.0.73.0.7.rc13.0.7.rc23.0.83.0.8.rc13.0.8.rc23.0.8.rc43.0.93.0.9.rc13.0.9.rc33.0.9.rc43.0.9.rc5
3.0.11
actionpack
RubyGems
3.1.0 up to 3.1.2, plus listed versions
3.1.13.1.1.rc13.1.1.rc23.1.1.rc33.1.2.rc13.1.2.rc2
3.1.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4319 is a medium vulnerability (CVSS 4.3) in Rubyonrails Rails, published November 28, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.58%, the 75th percentile. Fixed in actionpack 3.0.11.

References

Show 12 moreShow less
MoveEnter Open