Every CVE Search/ Get API key

CVE-2011-4585

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change...

5.0 MediumFix available

CVE-2011-4585 is a medium vulnerability (CVSS 5.0) in Moodle, published February 29, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in moodle 1.9.9.dfsg2-2.1+squeeze3.

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Exploit likelihood

2.12%Up 0.9 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.0

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Record
CVE-2011-4585
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-16
Updated
2026-11-02
CVE List No score

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Record
CVE-2011-4585
Updated
2026-11-02
EUVDEUVD-2011-4510 No score

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Record
EUVD-2011-4510
Updated
2026-11-03
GitHub AdvisoriesGHSA-ffr2-q8c8-w5xj No score

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change...

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Record
GHSA-ffr2-q8c8-w5xj
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle
Debian:6.0
before 1.9.9.dfsg2-2.1+squeeze3, plus listed versions
1.9.9.dfsg2-2.11.9.9.dfsg2-2.1+squeeze11.9.9.dfsg2-2.1+squeeze2
1.9.9.dfsg2-2.1+squeeze3

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

MoveEnter Open