CVE-2011-4588
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect...
CVE-2011-4588 is a medium vulnerability (CVSS 5.0) in Moodle, published February 29, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in moodle 1.9.9.dfsg2-2.1+squeeze3.
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect data type, which allows remote attackers to bypass intended IP address restrictions via an XMLRPC request.
Exploit likelihood
What each source reports
NVD Score used
5.0
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect data type, which allows remote attackers to bypass intended IP address restrictions via an XMLRPC request.
- Record
CVE-2011-4588- CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect data type, which allows remote attackers to bypass intended IP address restrictions via an XMLRPC request.
- Record
CVE-2011-4588- Updated
- 2026-11-02
EUVDEUVD-2011-4513 No score
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect data type, which allows remote attackers to bypass intended IP address restrictions via an XMLRPC request.
- Record
EUVD-2011-4513- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c2gc-3pq9-wq9x No score
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect...
The ip_in_range function in mnet/lib.php in MNET in Moodle 1.9.x before 1.9.15 uses an incorrect data type, which allows remote attackers to bypass intended IP address restrictions via an XMLRPC request.
- Record
GHSA-c2gc-3pq9-wq9x- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodleDebian:6.0 |
before 1.9.9.dfsg2-2.1+squeeze3, plus listed versions 1.9.9.dfsg2-2.11.9.9.dfsg2-2.1+squeeze11.9.9.dfsg2-2.1+squeeze2 |
1.9.9.dfsg2-2.1+squeeze3 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
bugzilla.redhat.com/show_bug.cgi?id=761248
debian.org/security/2012/dsa-2421
moodle.org/mod/forum/discuss.php?d=191756
git.moodle.org/gw?p=moodle.git%3Ba=commit%3Bh=3ab2851d2a59721445945d0706c58092e07e861e
nvd.nist.gov/vuln/detail/CVE-2011-4588
git.moodle.org/gw?p=moodle.git;a=commit;h=3ab2851d2a59721445945d0706c58092e07e861e
github.com/advisories/GHSA-c2gc-3pq9-wq9x