CVE-2011-4625
simpleSAMLphp incorrectly handles XML encryption
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
CVE-2011-4625- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-755
- Updated
- 2026-11-02
CVE List No score
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
CVE-2011-4625- Updated
- 2026-11-02
EUVDEUVD-2022-1634 No score
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
EUVD-2022-1634- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-5fj7-f8x3-q2mc
7.5
simpleSAMLphp incorrectly handles XML encryption
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
GHSA-5fj7-f8x3-q2mc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-755
- Updated
- 2026-11-02
OSV
7.5
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
CVE-2011-4625- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2011-4625
7.5
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
DEBIAN-CVE-2011-4625- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-5fj7-f8x3-q2mc
7.5
simpleSAMLphp incorrectly handles XML encryption
simplesamlphp before 1.6.3 (squeeze) and before 1.8.2 (sid) incorrectly handles XML encryption which could allow remote attackers to decrypt or forge messages.
- Record
GHSA-5fj7-f8x3-q2mc- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-755
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
simplesamlphp/simplesamlphpPackagist |
before 1.8.1 | 1.8.1 |
simplesamlphpDebian:12 |
before 1.8.1-1 | 1.8.1-1 |
simplesamlphpDebian:14 |
before 1.8.1-1, plus listed versions 1.6.0-11.6.1-11.6.2-11.6.3-11.6.3-2 Show 4 moreShow less1.6.3-31.7.0-11.7.0-21.8.0-1 |
1.8.1-1 |
simplesamlphpDebian:6.0 |
before 1.6.3-2, plus listed versions 1.6.3-1 |
1.6.3-2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4625 is a high vulnerability (CVSS 7.5) in Simplesamlphp, published October 27, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in simplesamlphp/simplesamlphp 1.8.1.
References
security-tracker.debian.org/tracker/CVE-2011-4625
mageni.net/1.3.6.1.4.1.25623.1.0.70545
nvd.nist.gov/vuln/detail/CVE-2011-4625
github.com/simplesamlphp/simplesamlphp/blob/b3059c51a915910c6631fb2ee597c0fb6ad9162b/docs/simplesamlphp-changelog-1.x.md?plain=1
secure1.securityspace.com/smysecure/catid.html?in=DSA%202330-1
mageni.net/vulnerability/debian-security-advisory-dsa-2330-1-simplesamlphp-70545
github.com/advisories/GHSA-5fj7-f8x3-q2mc
github.com/simplesamlphp/simplesamlphp