CVE-2011-4630
Typo3 XSS Vulnerability
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
- Record
CVE-2011-4630- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
- Record
CVE-2011-4630- Updated
- 2026-11-02
EUVDEUVD-2022-1595 No score
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
- Record
EUVD-2022-1595- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-29wr-24h5-95r5
5.4
Typo3 XSS Vulnerability
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
- Record
GHSA-29wr-24h5-95r5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-29wr-24h5-95r5
5.4
Typo3 XSS Vulnerability
Cross-site Scripting (XSS) in TYPO3 before 4.3.12, 4.4.x before 4.4.9, and 4.5.x before 4.5.4 allows remote attackers to inject arbitrary web script or HTML via the browse_links wizard.
- Record
GHSA-29wr-24h5-95r5- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cmsPackagist |
4.5.0 up to 4.5.4 | 4.5.4 |
typo3/cmsPackagist |
4.4.0 up to 4.4.9 | 4.4.9 |
typo3/cmsPackagist |
before 4.3.12 | 4.3.12 |
typo3-srcDebian:5.0 From an advisory covering 12 CVEs |
before 4.2.5-1+lenny8, plus listed versions 4.2.5-14.2.5-1+lenny14.2.5-1+lenny24.2.5-1+lenny34.2.5-1+lenny44.2.5-1+lenny54.2.5-1+lenny6 |
4.2.5-1+lenny8 |
typo3-srcDebian:6.0 From an advisory covering 12 CVEs |
before 4.3.9+dfsg1-1+squeeze1, plus listed versions 4.3.9+dfsg1-1 |
4.3.9+dfsg1-1+squeeze1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4630 is a medium vulnerability (CVSS 5.4) in Typo3, published August 7, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.68%, the 52nd percentile. Fixed in typo3/cms 4.5.4.