CVE-2011-4904
Typo3 Improper Access Control
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
- Record
CVE-2011-4904- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:P/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
CVE List No score
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
- Record
CVE-2011-4904- Updated
- 2026-11-02
EUVDEUVD-2022-1811 No score
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
- Record
EUVD-2022-1811- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qf79-34j4-54m6
6.5
Typo3 Improper Access Control
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
- Record
GHSA-qf79-34j4-54m6- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-qf79-34j4-54m6
6.5
Typo3 Improper Access Control
TYPO3 before 4.4.9 and 4.5.x before 4.5.4 does not apply proper access control on ExtDirect calls which allows remote attackers to retrieve ExtDirect endpoint services.
- Record
GHSA-qf79-34j4-54m6- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
typo3/cmsPackagist |
before 4.4.9 | 4.4.9 |
typo3/cmsPackagist |
4.5.0 up to 4.5.4 | 4.5.4 |
typo3-srcDebian:5.0 From an advisory covering 12 CVEs |
before 4.2.5-1+lenny8, plus listed versions 4.2.5-14.2.5-1+lenny14.2.5-1+lenny24.2.5-1+lenny34.2.5-1+lenny44.2.5-1+lenny54.2.5-1+lenny6 |
4.2.5-1+lenny8 |
typo3-srcDebian:6.0 From an advisory covering 12 CVEs |
before 4.3.9+dfsg1-1+squeeze1, plus listed versions 4.3.9+dfsg1-1 |
4.3.9+dfsg1-1+squeeze1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2011-4904 is a medium vulnerability (CVSS 6.5) in Typo3, published August 7, 2011. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.14%, the 66th percentile. Fixed in typo3/cms 4.4.9.