Every CVE Search/ Get API key

CVE-2011-4924

Zope XSS Vulnerability

6.1 MediumFix available

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

1.36%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 6.1

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
CVE-2011-4924
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
CVE-2011-4924
Updated
2026-11-02
EUVDEUVD-2022-1838 No score

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
EUVD-2022-1838
Updated
2026-11-03
GitHub AdvisoriesGHSA-vh6g-786f-hxxp 6.1

Zope XSS Vulnerability

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
GHSA-vh6g-786f-hxxp
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-vh6g-786f-hxxp 6.1

Zope XSS Vulnerability

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
GHSA-vh6g-786f-hxxp
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-3440 6.1

Zope XSS Vulnerability

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
PYSEC-2026-3440
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVPYSEC-2026-766 6.1

Zope XSS Vulnerability

Cross-site scripting (XSS) vulnerability in Zope 2.8.x before 2.8.12, 2.9.x before 2.9.12, 2.10.x before 2.10.11, 2.11.x before 2.11.6, and 2.12.x before 2.12.3, 3.1.1 through 3.4.1. allows remote attackers to inject arbitrary web script or HTML via vectors related to the way error messages perform sanitization. NOTE: this issue exists because of an incomplete fix for CVE-2010-1104

Record
PYSEC-2026-766
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zope
PyPI
3.1.1 up to 3.7.3
3.7.3
zope2
PyPI
before 2.12.22
2.12.22
zope2
PyPI
2.13.0a1 up to 2.13.12
2.13.12
zope2
PyPI
before 2.12.22, plus listed versions
2.12.02.12.0.a12.12.0a22.12.0a32.12.0a4
Show 26 moreShow less
2.12.0b12.12.0b22.12.0b32.12.0b42.12.0c12.12.12.12.102.12.112.12.122.12.132.12.142.12.152.12.162.12.172.12.182.12.192.12.22.12.202.12.212.12.32.12.42.12.52.12.62.12.72.12.82.12.9
2.12.22
zope2
PyPI
2.13.0a1 up to 2.13.12, plus listed versions
2.13.02.13.0a22.13.0a32.13.0a42.13.0b1
Show 12 moreShow less
2.13.0c12.13.12.13.102.13.112.13.22.13.32.13.42.13.52.13.62.13.72.13.82.13.9
2.13.12
zope2
PyPI
before 2.12.22, 2.13.0a1 up to 2.13.12, plus listed versions
2.12.02.12.0.a12.12.0a22.12.0a32.12.0a4
Show 43 moreShow less
2.12.0b12.12.0b22.12.0b32.12.0b42.12.0c12.12.12.12.102.12.112.12.122.12.132.12.142.12.152.12.162.12.172.12.182.12.192.12.22.12.202.12.212.12.32.12.42.12.52.12.62.12.72.12.82.12.92.13.02.13.0a22.13.0a32.13.0a42.13.0b12.13.0c12.13.12.13.102.13.112.13.22.13.32.13.42.13.52.13.62.13.72.13.82.13.9
2.12.222.13.12

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2011-4924 is a medium vulnerability (CVSS 6.1) in Zope, published November 25, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in zope 3.7.3.

References

Show 8 moreShow less
MoveEnter Open