Every CVE Search/ Get API key

CVE-2012-0797

Moodle Users Can Bypass Deleted Status

5.5 MediumFix available

CVE-2012-0797 is a medium vulnerability (CVSS 5.5) in Moodle, published July 17, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.09%, the 65th percentile. Fixed in moodle/moodle 2.2.1.

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Exploit likelihood

1.09%Unchanged since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Record
CVE-2012-0797
CVSS 2.0
5.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:N
Weakness
CWE-16
Updated
2026-11-02
CVE List No score

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Record
CVE-2012-0797
Updated
2026-11-02
EUVDEUVD-2022-2890 No score

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Record
EUVD-2022-2890
Updated
2026-11-03
GitHub AdvisoriesGHSA-72gv-qqrp-h9qg No score

Moodle Users Can Bypass Deleted Status

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Record
GHSA-72gv-qqrp-h9qg
Weakness
CWE-287
Updated
2026-11-02
OSVGHSA-72gv-qqrp-h9qg No score

Moodle Users Can Bypass Deleted Status

The webservices functionality in Moodle 2.0.x before 2.0.7, 2.1.x before 2.1.4, and 2.2.x before 2.2.1 allows remote authenticated users to bypass the deleted status and continue using a server via a token.

Record
GHSA-72gv-qqrp-h9qg
Weakness
CWE-287
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
2.2 up to 2.2.1
2.2.1
moodle/moodle
Packagist
2.1 up to 2.1.4
2.1.4
moodle/moodle
Packagist
2.0 up to 2.0.7
2.0.7

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 4 moreShow less
MoveEnter Open