Every CVE Search/ Get API key

CVE-2012-0834

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier...

4.3 MediumPublic exploitFix available

CVE-2012-0834 is a medium vulnerability (CVSS 4.3) in Phpldapadmin Project Phpldapadmin, published February 11, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.79%, the 91st percentile. Fixed in phpldapadmin 1.2.2-1.

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Exploit likelihood

4.79%Up 2.2 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
CVE-2012-0834
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
CVE-2012-0834
Updated
2026-11-02
EUVDEUVD-2012-0860 No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
EUVD-2012-0860
Updated
2026-11-03
GitHub AdvisoriesGHSA-h3h7-fqg9-32f3 No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier...

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
GHSA-h3h7-fqg9-32f3
Weakness
CWE-79
Updated
2026-11-02
OSV No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
CVE-2012-0834
Updated
2026-11-02
OSVDEBIAN-CVE-2012-0834 No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
DEBIAN-CVE-2012-0834
Updated
2026-11-02
OSVUBUNTU-CVE-2012-0834 No score

Cross-site scripting (XSS) vulnerability in lib/QueryRender.php in phpLDAPadmin 1.2.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the base parameter in a query_engine action to cmd.php.

Record
UBUNTU-CVE-2012-0834
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpldapadmin
Debian:12
before 1.2.2-1
1.2.2-1
phpldapadmin
Debian:13
before 1.2.2-1
1.2.2-1
phpldapadmin
Debian:14
before 1.2.2-1
1.2.2-1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
Exploit-DBphpLDAPadmin 1.2.2 - 'base' Cross-Site Scripting2012-02-01

History

History
WhenChangedSources
2026-11-03affected
2026-11-03aliasesEUVD
2026-11-02createdCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

References

Show 6 moreShow less
MoveEnter Open