CVE-2012-20001
PrestaShop XSS Vulnerability
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
- Record
CVE-2012-20001- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
- Record
CVE-2012-20001- Updated
- 2026-11-02
EUVDEUVD-2022-1765 No score
PrestaShop before 1.5.2 allows XSS via the "<object data='data:text/html" substring in the message field.
- Record
EUVD-2022-1765- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-j33m-2537-86jm
6.1
PrestaShop XSS Vulnerability
PrestaShop before 1.5.2.0 allows XSS via the <object data='data:text/html substring in the message field.
- Record
GHSA-j33m-2537-86jm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-j33m-2537-86jm
6.1
PrestaShop XSS Vulnerability
PrestaShop before 1.5.2.0 allows XSS via the <object data='data:text/html substring in the message field.
- Record
GHSA-j33m-2537-86jm- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
prestashop/prestashopPackagist |
before 1.5.2.0 | 1.5.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-20001 is a medium vulnerability (CVSS 6.1) in Prestashop, published December 21, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.82%, the 57th percentile. Fixed in prestashop/prestashop 1.5.2.0.