CVE-2012-2085
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote...
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
Exploit likelihood
What each source reports
NVD Score used
6.8
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
CVE-2012-2085- CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-94
- Updated
- 2026-11-02
CVE List No score
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
CVE-2012-2085- Updated
- 2026-11-02
EUVDEUVD-2012-2091 No score
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
EUVD-2012-2091- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m3cr-88v9-chgp No score
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote...
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
GHSA-m3cr-88v9-chgp- Weakness
- CWE-94
- Updated
- 2026-11-02
OSV No score
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
CVE-2012-2085- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-2085 No score
The exec_command function in common/helpers.py in Gajim before 0.15 allows user-assisted remote attackers to execute arbitrary commands via shell metacharacters in an href attribute.
- Record
DEBIAN-CVE-2012-2085- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gajimDebian:12 |
before 0.15-1 | 0.15-1 |
gajimDebian:13 |
before 0.15-1 | 0.15-1 |
gajimDebian:14 |
before 0.15-1 | 0.15-1 |
gajimDebian:6.0 From an advisory covering 3 CVEs |
before 0.13.4-3+squeeze2, plus listed versions 0.13.4-30.13.4-3+squeeze1 |
0.13.4-3+squeeze2 |
gajimDebian:6.0 From an advisory covering 3 CVEs |
before 0.13.4-3+squeeze3, plus listed versions 0.13.4-30.13.4-3+squeeze10.13.4-3+squeeze2 |
0.13.4-3+squeeze3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-2085 is a medium vulnerability (CVSS 6.8) in Gajim, published April 16, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.18%, the 88th percentile. Fixed in gajim 0.15-1.