Every CVE Search/ Get API key

CVE-2012-2142

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute...

7.8 HighFix available

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.94%Up 1.6 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 7.8

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
CVE-2012-2142
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Updated
2026-11-02
CVE List No score

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
CVE-2012-2142
Updated
2026-11-02
EUVDEUVD-2012-2139 No score

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
EUVD-2012-2139
Updated
2026-11-03
GitHub AdvisoriesGHSA-pwcf-7grp-gwmj No score

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute...

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
GHSA-pwcf-7grp-gwmj
Updated
2026-11-02
OSV 7.8

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
CVE-2012-2142
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2142 7.8

The error function in Error.cc in poppler before 0.21.4 allows remote attackers to execute arbitrary commands via a PDF containing an escape sequence for a terminal emulator.

Record
DEBIAN-CVE-2012-2142
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2013-0261 No score

Updated xpdf packages fixes security vulnerability

PDF files could be used to inject shell code when xpdf was run from some terminal emulators, due to the use of escape sequences in error messages (CVE-2012-2142).

Record
MGASA-2013-0261
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
poppler
Debian:12
before 0.18.4-7
0.18.4-7
poppler
Debian:13
before 0.18.4-7
0.18.4-7
poppler
Debian:14
before 0.18.4-7
0.18.4-7
xpdf
Mageia:2
before 3.03-2.1.mga2
3.03-2.1.mga2
xpdf
Mageia:3
before 3.03-4.1.mga3
3.03-4.1.mga3

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2142 is a high vulnerability (CVSS 7.8) in Freedesktop Poppler, published August 26, 2013. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.94%, the 87th percentile. Fixed in poppler 0.18.4-7.

References

Show 6 moreShow less
MoveEnter Open