CVE-2012-2356
Moodle Authentication Bypass in Question-Bank
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
Exploit likelihood
What each source reports
NVD Score used
4.0
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
CVE-2012-2356- CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-264
- Updated
- 2026-11-02
CVE List No score
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
CVE-2012-2356- Updated
- 2026-11-02
EUVDEUVD-2022-2237 No score
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
EUVD-2022-2237- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3rqj-jchw-9cc7 No score
Moodle Authentication Bypass in Question-Bank
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
GHSA-3rqj-jchw-9cc7- Weakness
- CWE-288
- Updated
- 2026-11-02
OSVGHSA-3rqj-jchw-9cc7 No score
Moodle Authentication Bypass in Question-Bank
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
GHSA-3rqj-jchw-9cc7- Weakness
- CWE-288
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2012-2356 No score
The question-bank functionality in Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass intended capability requirements and save questions via a save_question action.
- Record
UBUNTU-CVE-2012-2356- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
2.1 up to 2.1.6 | 2.1.6 |
moodle/moodlePackagist |
2.2 up to 2.2.3 | 2.2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-2356 is a medium vulnerability (CVSS 4.0) in Moodle, published July 21, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.41%, the 72nd percentile. Fixed in moodle/moodle 2.1.6.
References
openwall.com/lists/oss-security/2012/05/23/2
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-32239
nvd.nist.gov/vuln/detail/CVE-2012-2356
github.com/moodle/moodle/commit/0f83dd10a1d013e77906c7be4560126bb14c6b5c
github.com/moodle/moodle/commit/29e247e44e983f230f248192ffac8e7b7abe37fd
github.com/moodle/moodle/commit/51c5e6057c67687f5d872f8a228cfea275abf576