CVE-2012-2698
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php...
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
Exploit likelihood
What each source reports
NVD Score used
4.3
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
CVE-2012-2698- CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
CVE-2012-2698- Updated
- 2026-11-02
EUVDEUVD-2012-2678 No score
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
EUVD-2012-2678- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m9wp-hhqp-ww9j No score
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php...
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
GHSA-m9wp-hhqp-ww9j- Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
CVE-2012-2698- Updated
- 2026-11-02
OSVDEBIAN-CVE-2012-2698 No score
Cross-site scripting (XSS) vulnerability in the outputPage function in includes/SkinTemplate.php in MediaWiki before 1.17.5, 1.18.x before 1.18.4, and 1.19.x before 1.19.1 allows remote attackers to inject arbitrary web script or HTML via the uselang parameter to index.php/Main_page.
- Record
DEBIAN-CVE-2012-2698- Updated
- 2026-11-02
Affected products
Affected packages
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | MediaWiki 1.x - 'uselang' Cross-Site Scripting | 2012-06-17 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2012-2698 is a medium vulnerability (CVSS 4.3) in Mediawiki, published June 29, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 4.89%, the 92nd percentile. Fixed in mediawiki 1:1.19.1-1.
References
lists.wikimedia.org/pipermail/mediawiki-announce/2012-June/000116.html
mediawiki.org/wiki/Release_notes/1.18
osvdb.org/82983
lists.wikimedia.org/pipermail/mediawiki-announce/2012-June/000117.html
secunia.com/advisories/49484
bugzilla.wikimedia.org/show_bug.cgi?id=36938
Show 10 moreShow less
securitytracker.com/id?1027179
mediawiki.org/wiki/Release_notes/1.19
exchange.xforce.ibmcloud.com/vulnerabilities/76311
mediawiki.org/wiki/Release_notes/1.17
gerrit.wikimedia.org/r
openwall.com/lists/oss-security/2012/06/14/2
lists.wikimedia.org/pipermail/mediawiki-announce/2012-June/000118.html
nvd.nist.gov/vuln/detail/CVE-2012-2698
github.com/advisories/GHSA-m9wp-hhqp-ww9j
security-tracker.debian.org/tracker/CVE-2012-2698