Every CVE Search/ Get API key

CVE-2012-2738

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause...

4.0 MediumPublic exploitFix available

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Exploit likelihood

11.2%Down 1.0 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.0

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
CVE-2012-2738
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:N/A:P
Weakness
CWE-119
Updated
2026-11-02
CVE List No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
CVE-2012-2738
Updated
2026-11-02
EUVDEUVD-2012-2718 No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
EUVD-2012-2718
Updated
2026-11-03
GitHub AdvisoriesGHSA-55r6-7773-xfwg No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause...

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
GHSA-55r6-7773-xfwg
Weakness
CWE-119
Updated
2026-11-02
OSVOESA-2022-1648 6.5

vte security update

VTE is a terminal emulator widget for use with GTK+ 2.0.

Security Fix(es):

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.(CVE-2012-2738)

Record
OESA-2022-1648
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVALPINE-CVE-2012-2738 No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
ALPINE-CVE-2012-2738
Updated
2026-11-03
Show 4 moreShow less
OSV No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
CVE-2012-2738
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2738 No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
DEBIAN-CVE-2012-2738
Updated
2026-11-02
OSVopenSUSE-SU-2024:10407-1 No score

glade3-catalog-vte-0.28.2-22.1 on GA media

These are all security issues fixed in the glade3-catalog-vte-0.28.2-22.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10407-1
Updated
2026-11-02
OSVUBUNTU-CVE-2012-2738 No score

The VteTerminal in gnome-terminal (vte) before 0.32.2 allows remote authenticated users to cause a denial of service (long loop and CPU consumption) via an escape sequence with a large repeat count value.

Record
UBUNTU-CVE-2012-2738
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
vte
Alpine:v3.10
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.11
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.12
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.13
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.14
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.6
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.7
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.8
before 0.28.2-r12
0.28.2-r12
vte
Alpine:v3.9
before 0.28.2-r12
0.28.2-r12
vte
Debian:12
before 1:0.28.2-5
1:0.28.2-5
vte
Debian:13
before 1:0.28.2-5
1:0.28.2-5
vte
Debian:14
before 1:0.28.2-5
1:0.28.2-5
vte
openEuler:22.03-LTS
before 0.28.2-4.oe2203
0.28.2-4.oe2203

Public exploits

Links only. Every CVE stores no exploit code.

History

History
RecordedChangedSources
affectedOSV
affected
aliasesEUVD
first indexedCVE List, Exploit-DB, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2738 is a medium vulnerability (CVSS 4.0) in Nalin Dahyabhai Vte, published July 22, 2012. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 11.2%, the 95th percentile. Fixed in vte 0.28.2-r12.

References

Show 12 moreShow less
MoveEnter Open