Every CVE Search/ Get API key

CVE-2012-2751

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the...

4.3 MediumFix available

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Exploit likelihood

3.30%Down 0.1 points since Feb 4, 2022
90%50%10%1%

What each source reports

NVD Score used 4.3

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
CVE-2012-2751
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Updated
2026-11-02
CVE List No score

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
CVE-2012-2751
Updated
2026-11-02
EUVDEUVD-2012-2731 No score

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
EUVD-2012-2731
Updated
2026-11-03
GitHub AdvisoriesGHSA-38m7-p7j8-c694 No score

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the...

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
GHSA-38m7-p7j8-c694
Updated
2026-11-02
OSV No score

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
CVE-2012-2751
Updated
2026-11-02
OSVDEBIAN-CVE-2012-2751 No score

ModSecurity before 2.6.6, when used with PHP, does not properly handle single quotes not at the beginning of a request parameter value in the Content-Disposition field of a request with a multipart/form-data Content-Type header, which allows remote attackers to bypass filtering rules and perform other attacks such as cross-site scripting (XSS) attacks. NOTE: this vulnerability exists because of an incomplete fix for CVE-2009-5031.

Record
DEBIAN-CVE-2012-2751
Updated
2026-11-02
OSVopenSUSE-SU-2024:10034-1 No score

apache2-mod_security2-2.9.0-5.6 on GA media

These are all security issues fixed in the apache2-mod_security2-2.9.0-5.6 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10034-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
modsecurity-apache
Debian:12
before 2.6.6-1
2.6.6-1
modsecurity-apache
Debian:13
before 2.6.6-1
2.6.6-1
modsecurity-apache
Debian:14
before 2.6.6-1
2.6.6-1
libapache-mod-security
Debian:6.0
before 2.5.12-1+squeeze1, plus listed versions
2.5.12-1
2.5.12-1+squeeze1
apache2-mod_security2
openSUSE:Tumbleweed
before 2.9.0-5.6
2.9.0-5.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2012-2751 is a medium vulnerability (CVSS 4.3) in Trustwave Modsecurity, published July 2, 2012. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.30%, the 88th percentile. Fixed in modsecurity-apache 2.6.6-1.

References

Show 18 moreShow less
MoveEnter Open